1.8 Bukkit Discussion

Discussion in 'Bukkit Discussion' started by agafaba, Sep 14, 2011.

Thread Status:
Not open for further replies.
  1. Offline


  2. Offline


    for those wondering about NPC villages spawning, try the seed "666" with the build, there should be a village right nearby, for a true test.

    Edit: my question here is, especially with that seed, the village was placed in a horrible place (the road dropped off in places and some huts were half in the ground and unenterable), notch said he fixed poorly placed villages and they could only be placed on flat areas, so for a village like that, i wonder if his "fix" is giving off that error and causing them not to spawn.
  3. Offline


    I am running 1149 and I've found a stronghold and 3 villages so far. I think it might just be luck of the draw?
  4. Offline


    it's a matter of the seed you are using
  5. Will there be a way to convert our 1.7 maps to 1.8 maps ?
  6. Offline


    Running on 1150 for 14 hours without any problems so far. :)

    But the Enderman is still just decoration :D
  7. Offline


    I havn't read all the posts in this thread but i did do a brief search. Anyways is the bukkit team aware that arrows from a dispenser killing someone will crash the server instantly? I tested it on my server with build 1149 and it works. Could be they already fixed it, but i didnt see anything in the changelog. I will just disable dispenser usage until i find a better solution.
  8. Offline

    Emiya Shirou

    I see, well i try with 1135 since this is the only one available from my hosting and fly in search for a village then.
  9. Offline


    I'm running 1152 and no problems so far.
  10. 1152 runs pretty good for about 12 hours.. Then it bugs out where it will keep running but commands won't respond so I have to manually close it and then start it back up.
  11. Offline


    It lags very much but at 1.7.3 I had never lag. Does that come from 1.8 or dev version of bukkit.
  12. Offline


    Has the rare bug been fixed yet where Chests can turn in to Furnaces? I was reading CraftBukkit's tweets about it a day or two ago. That's a pretty scary bug.
  13. Offline


    due to the fact that seeds in 1.7.3 no longer make the same worlds in 1.8, you CAN, but your world will have slices that dont match up when you explore new regions. i know it works cause i tested our world in single player in 1.8 and it worked just fine, but had the odd slices like i said.

    Edit: im sure you risk losing a stronghold, etc, if your world is already pretty big, because one of the regions you already have could have contained a stronghold if it were newly spawned from 1.8
  14. Offline


    I don't know if this is a vanilla bug or not or if it's been reported, haven't checked.. But when you go to place a block in creative mode while another player is in your cross-hair away from you, you cannot place nor does the block you are looking at to place on receive a black outline..
  15. Offline


    the 666 seed worked... so it must just be the seed. im pretty sure some (read, most...) seeds simply do not spawn villages or strongholds.
  16. Offline


    or are just out further. there is a thread... somewhere, i think on this forum... where someone was using the seed with an algorithm he had to find strongholds near the spawn point, and it worked every time. again i think its just poor luck in trying to find them
  17. Offline


    the strongholds i havent really searched for intensively. but for certain the villages. is there a map analyzer or whatever like they have in terraria? that would solve it pretty quickly.

    actually, dont new chunks generate as you encounter them? idk.. idk how that works @.@
  18. Offline


    yes, unless you use one of those plugins that generates the chunks do a certain degree ahead of time for you to reduce the lag of them being created. all in all, it doesnt realy matter cause a seed will always output the same world design, with slight minimal differences. edit: except in 1.8 where they are different than they were in previous versions.
  19. Offline


    Wrong. You just have to know how to use FTP clients. I've kept my McMyAdmin up to date with these dev builds easily.
  20. Offline


    yeah he should just upload the bukkit.jar file to his directory. its that easy xD
  21. Offline


    I find that very few people on this forum are anywhere near polite. If you ask a question that certain people believe that should be common knowledge, then those people with attack you and call you terrible things.
  22. Offline


    Quick question - in one of the newest changes in the dev version, an item is listed:

    Am I misunderstanding this change? Health regen happens in all modes as long as you're fed in vanilla minecraft. Does this item mean that the feature is being taken out in bukkit?
  23. Offline


    as far as i know its just making it so in peaceful you always regen. but i could be wrong
  24. Offline


    I'm not one of them. :)
  25. Offline


    im still running on #1149. works good.
    any newer build working stabil too?
    im afraid to change it.
    "never change a running system"
    quick reply would be cool =)
  26. Offline


    Yes, newer builds are more stable due more bug fixes. Go for latest successful build.
  27. Offline


    thx man, i'll give it a try!
  28. Offline

    Rocket Widget

    161 recipes
    17 achievements
    02:20:23 [INFO] Starting minecraft server version Beta 1.8.1
    02:20:23 [INFO] Loading properties
    02:20:23 [INFO] Starting Minecraft server on *:25565
    02:20:23 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1043-gab6dd01-b1145jnks (MC: 1.8.1)
    02:20:23 [INFO] Preparing level "world"
    02:20:23 [INFO] Default game type: 0
    02:20:23 [INFO] Unable to find spawn biome
    02:20:23 [SEVERE] java.lang.NullPointerException
    02:20:23 [SEVERE]       at net.minecraft.server.WorldServer.c(WorldServer.java:106)
    02:20:23 [SEVERE]       at net.minecraft.server.World.a(World.java:2217)
    02:20:23 [SEVERE]       at net.minecraft.server.Chunk.addEntities(Chunk.java:629)
    02:20:23 [SEVERE]       at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:81)
    02:20:23 [SEVERE]       at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(ChunkProviderServer.java:106)
    02:20:23 [SEVERE]       at net.minecraft.server.World.getChunkAt(World.java:300)
    02:20:23 [SEVERE]       at net.minecraft.server.World.getTypeId(World.java:247)
    02:20:23 [SEVERE]       at net.minecraft.server.World.isEmpty(World.java:251)
    02:20:23 [SEVERE]       at net.minecraft.server.World.a(World.java:218)
    02:20:23 [SEVERE]       at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
    02:20:23 [SEVERE]       at net.minecraft.server.World.canSpawn(World.java:104)
    02:20:23 [SEVERE]       at net.minecraft.server.World.c(World.java:202)
    02:20:23 [SEVERE]       at net.minecraft.server.World.<init>(World.java:150)
    02:20:23 [SEVERE]       at net.minecraft.server.WorldServer.<init>(WorldServer.java:27)
    02:20:23 [SEVERE]       at net.minecraft.server.SecondaryWorldServer.<init>(SecondaryWorldServer.java:8)
    02:20:23 [SEVERE]       at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:221)
    02:20:23 [SEVERE]       at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
    02:20:23 [SEVERE]       at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
    02:20:23 [SEVERE]       at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    02:20:23 [SEVERE] Unexpected exception
            at net.minecraft.server.WorldServer.c(WorldServer.java:106)
            at net.minecraft.server.World.a(World.java:2217)
            at net.minecraft.server.Chunk.addEntities(Chunk.java:629)
            at net.minecraft.server.ChunkProviderServer.getChunkAt(ChunkProviderServer.java:81)
            at net.minecraft.server.ChunkProviderServer.getOrCreateChunk(ChunkProviderServer.java:106)
            at net.minecraft.server.World.getChunkAt(World.java:300)
            at net.minecraft.server.World.getTypeId(World.java:247)
            at net.minecraft.server.World.isEmpty(World.java:251)
            at net.minecraft.server.World.a(World.java:218)
            at net.minecraft.server.WorldProviderHell.canSpawn(SourceFile:37)
            at net.minecraft.server.World.canSpawn(World.java:104)
            at net.minecraft.server.World.c(World.java:202)
            at net.minecraft.server.World.<init>(World.java:150)
            at net.minecraft.server.WorldServer.<init>(WorldServer.java:27)
            at net.minecraft.server.SecondaryWorldServer.<init>(SecondaryWorldServer.java:8)
            at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:221)
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
    I get this error with any version I try
  29. Offline


    honestly i think thats about 90% of the forums on the internet :p but i know how you feel
  30. Offline


    get this error with 1166 and pex 1.13 ... with the devs before it worked...
    [SEVERE] Error occurred while enabling PermissionsEx v1.13 (Is it up to date?): org.bukkit.plugin.PluginDescriptionFile.getPermissions()Ljava/util/ArrayList;
    java.lang.NoSuchMethodError: org.bukkit.plugin.PluginDescriptionFile.getPermissions()Ljava/util/ArrayList;
        at ru.tehkode.permissions.bukkit.BukkitPermissions.collectPermissions(BukkitPermissions.java:105)
        at ru.tehkode.permissions.bukkit.BukkitPermissions.<init>(BukkitPermissions.java:73)
        at ru.tehkode.permissions.bukkit.PermissionsEx.onEnable(PermissionsEx.java:103)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:126)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:906)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:278)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:173)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:156)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:297)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:284)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:152)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:348)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:417)
Thread Status:
Not open for further replies.

Share This Page