Solved (1.5.2) ShowCaseStandalone, giving error

Discussion in 'Bukkit Help' started by Priitney, Jun 22, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    Hello, I'd just like to say that I think (really, personally) shops with floating items on slabs are the most handsome looking shops of all :) back then I used to play in other servers, and found a server which used this plugin and I really enjoyed it.

    I'm in progress making my own server now, unfortunately there's something wrong with the plugin :( and I'd Really Really would love to get it to work properly!

    The error I am receiving as I type in the command to create a showcase "/scs sell this 64 2" ("this" = item I am holding, yeah I tested with many different items still the same)

    Also inside the bukkit server console there's some mess going on when I type the in-game command to create a showcase.
    Show Spoiler
    19:59:50 [INFO] Alien_Technology issued server command: /scs sell this 1 1
    19:59:50 [SEVERE] null
    org.bukkit.command.CommandException: Unhandled exception executing command 'scs'
    in plugin ShowCaseStandalone v383
    at org.bukkit.command.PluginCommand.execute(
    at org.bukkit.command.SimpleCommandMap.dispatch(
    at org.bukkit.craftbukkit.v1_5_R3.CraftServer.dispatchCommand(CraftServe
    at net.minecraft.server.v1_5_R3.PlayerConnection.handleCommand(PlayerCon
    at net.minecraft.server.v1_5_R3.PlayerConnection.a(
    at net.minecraft.server.v1_5_R3.Packet3Chat.handle(
    at net.minecraft.server.v1_5_R3.NetworkManager.b(
    at net.minecraft.server.v1_5_R3.PlayerConnection.d(
    at net.minecraft.server.v1_5_R3.ServerConnection.b(SourceFile:35)
    at net.minecraft.server.v1_5_R3.DedicatedServerConnection.b(SourceFile:3
    at net.minecraft.server.v1_5_R3.MinecraftServer.r(
    at net.minecraft.server.v1_5_R3.DedicatedServer.r(
    at net.minecraft.server.v1_5_R3.MinecraftServer.q(
    Caused by: java.lang.NoClassDefFoundError: net/minecraft/server/v1_4_6/NBTBase
    at com.kellerkindt.scs.commands.SellCmd.execute(
    at com.kellerkindt.scs.listeners.CommandExecutorListener.onCommand(Comma
    at org.bukkit.command.PluginCommand.execute(
    ... 16 more
    Caused by: java.lang.ClassNotFoundException: net.minecraft.server.v1_4_6.NBTBase

    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    ... 19 more

    Why is this happening? The only economy plugin I use, is the one which comes with essentials by default. I installed "Vault" to see if it changes anything, it didn't the error still occurs.

    Thanks, maybe someone finds a moment to help me out. I love this plugin so much!

    I already regret for making this thread and being so stupid :D. And I really apologize, I'm still learning my way around in plugins list and I often miss out the important information that authors provide such as "development builds" in end of their posts, and the one I'm using now is a development build of this plugin for 1.5.2

    I downloaded the one on top left corner "[​IMG] #601 May 31, 2013 5:43:20 PM" and it magically works, just as I would of expected it to work and I haven't noticed any problems so far.

    Thanks and my apologizes again for polluting the board ._.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 2, 2016
Thread Status:
Not open for further replies.

Share This Page