1.2

Discussion in 'Bukkit Discussion' started by TheMaa, Mar 1, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    TheMaa

    Hello, I know we got a warning that our plugins might break, I just tested my server, and almost every plugin broke..
    Hawkeye, vault, pex and backup is the only plugins that work..

    Hate updates =(
     
  2. Offline

    Abrupt

    uh, ok..?
    wrong section.
     
  3. Offline

    NuclearW

    And off to the right section with ye
     
    tyzoid and Windows_i7_920 like this.
  4. Offline

    NotoriousNova

    Hey can someone please link me to the latest 1.2 pre-release? Thanks.
     
  5. Offline

    TheMaa

  6. Offline

    NotoriousNova

  7. Offline

    FuRiouSOne

    no plugins work with 1995 bukkit dev....... Looks every single plugin has to update before anyone can even run 1.2 server. This is truly sad. Here goes 2 months of no 1.2..

    Might have been best to have waited till AFTER 1.2 to do all these major bukkit changes.

    Also what is up with the map conversion? It just doubled my 2GB world folder to 4GB now lol. Made a full copy of all the region files for what?
     
  8. Offline

    greatman

    It keeps the old files (.mcr if I remember)
     
  9. Offline

    TheMaa

    I use mostly outdated plugins, worked fine with 1.1, but since they had this mayor change, only pex, hawkeye (unoffical) and vault works.. I am considering closing my server..
     
    jorisk322 likes this.
  10. Offline

    FuRiouSOne

    Right, but what im asking is whats the point in doubling the world folder size? Why not convert and REMOVE old files. I feel sorry for servers running 10GB+ worlds....
     
  11. Offline

    greatman

    Better to keep them if the convert failed or something ;)
     
  12. Offline

    FuRiouSOne

    Might be best to revert back to 1.1 and wait a month like everyone else will have to...... Truly sad time of the year for bukkit servers.....
     
  13. Offline

    NotoriousNova

    This is strange, whenever I try to to put any plugins into my plugin folder while running 1.2 pre-release it goes to an error whenever you try and login. I used essentials, nocheat, mcmmo and world edit as plugins and none of them worked. So now I'm back to vanilla. I am dedicated too by the ways.
     
  14. Offline

    FuRiouSOne

    You have to wait till ALL plugins are working towards 1.2 bukkit. Essentials loads like 10% but always errors out at the end, no luck getting ANYthing else to load.
     
  15. Offline

    TheMaa

    I did, but i don't think the developers of many plugins I use will update.
    Only solution, learing some java and start coding my own plugins :p
     
  16. Offline

    mpmumau

    Eek these are scary reports. I think I'm going to wait to upgrade until I hear more reports from testers. Is everyone having a similar experience with most plugins breaking?
     
  17. Offline

    TheMaa

    Here is my list, every plugin break with 1.2

    Edit: I have Hawkeye, vault and pex for 1.2 though

     
  18. Offline

    FuRiouSOne

    It is sad, there were some old GREAT plugins that always worked even when they were inactive till now, bukkit 1.2 just broke everything and every inactive plugin will NO longer work ever again......

    Guess its time for bukkit to take a dust pan to the plugin list page and remove every plugin that is not 1.2 compliant lol thats like 99.9% of the plugins on that list :mad:
     
  19. Offline

    mpmumau

    Looks like it's going to be a long couple weeks for server admins...ugh.
     
  20. Offline

    NotoriousNova

    Pex works for 1.2?
     
  21. Offline

    TheMaa

  22. QQ. Your tears are delicious.
     
    ZachBora likes this.
  23. Offline

    FuRiouSOne

    Yes even my tears are aching along with my head.... :'( Kind of to the point i want to replace the B on bukkit with an F and go play mw3/bf3/skyrim for a few days ^^
     
  24. Offline

    lmc

    Stop being so damn miserable and look on the bright side of life.
     
  25. Offline

    Snipes01

    Well if people would not always jump to the newest stuff their plugins would work. Every I mean every update there are user posting oh no I update trying to use new builds, but no everything is broken. Its fun to watch.
     
  26. Offline

    FuRiouSOne

    I do, im just giving bukkit a hard time :)..

    Dont worry my main server is still running R3 with all plugins and worlds intact. Everything i have tested is on my TEST server as any smart admin should do before updating their MAIN server :).

    Its just all the goofballs that decide to update their clients and scream and cry on the forums they cant log into the main server no longer lawl.
     
  27. Or just stick with 1.1 cause 1.1 was still "Fun" yesterday.
     
  28. Offline

    mpmumau

    It's actually not so surprising that people do. The Minecraft client forces strongly persuades users to update. Then they start complaining to server admins who know better than to immediately update, like, "Why can't I join? WTF! This server sucks!" Then we server admins go "Well, dang, I guess we're under the gun, then!" Then we update because we're under pressure and people say things like "Well, you should have waited to update!"

    It's really not that complicated to understand the psychology of it. If the Minecraft client didn't force strongly persuade users to update immediately, the transition would be easier. Of course, Mojang (historically) hasn't cared much for what happens in the Bukkit community -- they just do what they do, whenever it seems like the right time for them. Hopefully the newly announced partnership will help with these seemingly easy-to-fix cluster-f!$ks.

    Here's how the conversation could go:

    BUKKIT: Hey, Mojang, disable your auto-updater in the client, or time it with our updates, too.
    MOJANG: Ok!
    BUKKIT: Awesome! Problem solved, and lots of happy server admins!
     
  29. Offline

    ghost0001

    and this is why I wait for a RB AND all plugins to be updated.
     
  30. Offline

    TheMaa

    You can %appdata% -> Roaming>.minecraft-> "right click" ->'' click'' restore previous versions.
     
  31. Offline

    NotoriousNova

    Does anyone know a stable pre-release that doesn't have errors, and can run a anti-griefing plugin? I need players to be able to have secure home's and not be stolen from. I need a /spawn for them. Basically I need the important stuff.
     
Thread Status:
Not open for further replies.

Share This Page