[1.2.4] Craft Bukkit Error

Discussion in 'Bukkit Help' started by XMB Pax, Mar 22, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    XMB Pax

    I recently put the new 1.2.4 Craft Bukkit on my Minecraft server.
    When I try to use the command /pl or /plugins it kicks you and gives you this:
    [​IMG]
    Is this a bug in Craft Bukkit or does anyone know how to fix this?
     
  2. Offline

    n30nex

    This same error it me in a different way;

    CB for 1.2.4

    Joined, took out the new wood block, played with it, logged out with it in my hotbar, and cannot login for this error now. I had to delete my user profile in the world folder and essentials, and empty my inventory.
     
  3. Offline

    Mr_H4mm3r

    I think it has something to do with the craftbukkit title.. Remove the snapshot part :! But I'm not sure.. So it should be called: craftbukkit.jar
     
  4. Offline

    rtcabooservb

    Mine is called craftbukkit.jar but I still get the same errors with /warp, /plugins, and a long message in-game. Every command seems to only kick the person who says it but typing a long sentence will kick everyone.
     
  5. Offline

    n30nex

    .

    I am well aware, I've used the same batch file to start all the way from Hey0 days. I think this error is related to the protocol changes.
     
  6. Offline

    baem

    i can confirm this, everybody gets kicked if a chat is too long

    has anybody else the error that you see the new sandstone blocks as normal sandstone when you place them?
     
  7. Offline

    iLambo

    Yea, this same thing is happening to me. Its getting kinda dumb. If anybody has a fix, please post it here!
     
  8. Offline

    baem

    whats happening to you? my sandstone prob or getting kicked
     
  9. Offline

    BenTaylorUK

    Getting the same error on my server... not going to try to do and of the commands... but this does need to get fixed!

    EDIT: did /plugins... got the error
     
  10. Offline

    iLambo

    Well, to be honest I just play around and it kicks me. I told all my players to be quiet. Nobody talked and it kicks us. I placed the new blocks and that didn't do anything...

    The odd thing is I played other servers and they aren't having this problem...
     
  11. Offline

    Thisnamewilldo

    We're a big server and many of our players are unable to join due to this error, fix it please, URGENT!

    Internal exception: Java.io.IOException: Received string length longer than maximum allowed (122 > 119)
     
  12. Offline

    n30nex

    If people are trying to join your server but are prevented by the string too long error, and you run essentials or any other plugin that adds a MOTD upon login,

    Clear your MOTD. This allowed more then half of my regulars to login and play, it seems to be the long string that's tripping out the client protocol.
     
  13. Offline

    Lolmewn Retired Staff

  14. Offline

    Thisnamewilldo

    I do not have essentials I use command book.. I don't think that has an MOTD? If it does how do I clear it?
    Sometimes when I start the server it won't even start properly..
     
  15. Offline

    iLambo

    Look for "autmessages.properties" or something along those lines.

    Also, thanks n30nex. That stopped kicking everybody. Now we just need a chat update!

    Good news though, bukkit is releasing an update every like 15 minutes so hopefully my host and your hosts keeps up with them...
     
  16. Offline

    BenTaylorUK

  17. Offline

    winter4w

    Last edited by a moderator: May 24, 2016
  18. Offline

    iLambo

    Its all fixed with the latest version!

    I made my host update it and the chat error does not happen anymore.
     
  19. Offline

    TnT Retired Staff

    That's why we call them dev builds.

    Use at your own risk.
     
  20. Offline

    OldsCraft

    yes i have the same error and only 4 people can play on my server at once its kinda gay actually it needs to be fixed once it gets fixed though guys join my server 65.40.111.90
     
  21. Offline

    BenTaylorUK

    Nice huge text... I posted a fix above... also I believe the team have now fixed it so get the latest build or the first build for 1.2.4 from this link http://dl.bukkit.org/downloads/craftbukkit/list/dev/
     
    OldsCraft likes this.
  22. Offline

    OldsCraft

  23. Offline

    user_90563788

    I cleared the MOTD in Essentials and it started working.
     
  24. Offline

    BenTaylorUK

    You shouldn't have to do it with the first build I linked before... try one of the new builds too
     
  25. Offline

    user_90563788

    Now it's kicking everyone every 15 minutes or so (almost every player) and giving them the same error. They can reconnect immediately though.
    Edit: I realized whenever someone types a chat message that's too long, it kicks everyone from the sever.

    I'm using Beastnode and it doesn't look like they have an option to install specific builds, you just click the "update" button in the control panel and it updates to the latest one.
     
  26. Offline

    TheNoobWar

    Use the new dev builds, FYI using a dev build is at your own risk.
     
  27. Offline

    zipfe

    And so is using any other build, recommended or beta.
     
Thread Status:
Not open for further replies.

Share This Page