§ Symbol dosnt read

Discussion in 'Bukkit Help' started by Ablac, Aug 16, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    Ablac

    I'm currently running my Minecraft Server with CentOS and ever since 1.3.1 a lot of plugins are using § symbol for color codes which sucks cause CentOS isn't able to read it for some reason, it changes it to & id there any way to allow CentOS to read this symbol, as the plugins do not support the standard Minecraft Color Code Symbol.

    Thanks
     
  2. Offline

    Coelho

    CentOS is more than capable of reading that character...
     
  3. Offline

    Ablac

    Its not for some reason
     
  4. :p maybe try this &
     
  5. Inside the code for plugins, I always see §, but I always use & in-game ... (how do you even create that symbol ... I copied pasted this one).
     
  6. Offline

    Coelho

    You are supposed to use ChatColor.COLOR. Using § is BAD PRACTICE.
     
  7. *facepalm* I was talking about replacing colors like in colored signs or coloring chat. *facepalm*
    If I were to type &b + "string" , it wouldn't even work!
     
  8. Offline

    Coelho

    ChatColor.translateAlternateColorCodes('&', "&bMy colored String");
    *facepalm*
    YOU. ARE. BAD. PRACTICE.
     
  9. *FACEPALM* I already KNOW HOW TO USE chat colors smarty!!! I see other devs. using §, while I always use & instead!!! I'm not talking about how to use ChatColor, I'm just saying I see § instead of &.

    Wow
     
  10. Offline

    Ablac

    Ya for example MCBans uses § but doesn't accept & as the color Sigh, When it runs in the Console its changed to & which makes Mcbans Unable to read it and the chat comes across &4(TEXT) instead of in color it actually says &4(TEXT)
     
  11. Offline

    Coelho

    Reread your message a couple hundred times and then tell me, with a straight face, that you make any valid sense.

    Does it really matter if you have the color in console?
     
  12. Offline

    Ablac

    The color is displayed in-game usually but currently in-game if i had mcbans set to
    §2[MCBANS] It should look like this [MCBANS]
    But instead it looks like this in-game &2[MCBANS]

    Also looking at
    http://www.minecraftwiki.net/wiki/Formatting_codes
    They are showing the § symbol as the color code :/
     
  13. I'm saying in other DEVELOPERS' CODE (devs) I see the § sign used! I have always used the & sign. Is there anything complicated in that!!!

    And btw, to me, I made sense! You just mis-understood me!


    Ablac, do you understand what I'm saying?
     
  14. Offline

    Ablac

    nunber1_Master, I'm here to solve my issue, not get involved in a dispute about the color codes :)
     
    nunber1_Master likes this.
  15. Offline

    Coelho

    MCBans should replace a color character for you, so in the configurations you will only need to use an '&', not the special symbol.
     
  16. Offline

    Ablac

  17. Offline

    Coelho

  18. Offline

    Ablac

    Ya :/ So not sure what to do, I would love to ditch MCbans but we have other plugins that link through it.
     
  19. I've seen moderators use § in their code more than once!
     
  20. Offline

    Ablac

    And when MCbans boots this is the error im getting in the MCBans Config this is what that line is
    prefix: §4[§2Aerinia Law§4]§9

    So its changing them to ?

    Code:
    [SEVERE] Cannot load plugins/mcbans/settings.yml
    org.bukkit.configuration.InvalidConfigurationException: unacceptable character '?' (0xFFFD) special characters are not allowed
    in "<string>", position 139
        at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:55)
        at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:138)
        at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:105)
        at org.bukkit.configuration.file.YamlConfiguration.loadConfiguration(YamlConfiguration.java:175)
        at com.mcbans.firestar.mcbans.Settings.<init>(Settings.java:29)
        at com.mcbans.firestar.mcbans.BukkitInterface.onEnable(BukkitInterface.java:87)
        at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:217)
        at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337)
        at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:381)
        at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftServer.java:257)
        at org.bukkit.craftbukkit.CraftServer.enablePlugins(CraftServer.java:239)
        at net.minecraft.server.MinecraftServer.t(MinecraftServer.java:373)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:360)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:189)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:424)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: unacceptable character '?' (0xFFFD) special characters are not allowed
    in "<string>", position 139
        at org.yaml.snakeyaml.reader.StreamReader.checkPrintable(StreamReader.java:70)
        at org.yaml.snakeyaml.reader.StreamReader.<init>(StreamReader.java:50)
        at org.yaml.snakeyaml.Yaml.load(Yaml.java:399)
        at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:53)
        ... 15 more
    
    Ive got the same issue in CommandHelper, its using that symbol and if you change it to & it doesn't work​

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 27, 2016
  21. I would suggest taking it up with the plugin developer, as it seems more like a bug then a problem with CentOS.
     
  22. I've been using CentOS for years, and I can assure you it has no problem reading the character. The issue lies within SnakeYaml and its non-printable character range.

    Edit: There's a fix for it in SnakeYaml 1.11, due to be released soon I believe.
     
  23. Offline

    Ablac

    SnakeYaml? I'm assuming that's a CentOS Dependency, how do i check my version/install it. My CentOS is running without a desktop Session so its all SSH commands.
     
  24. SnakeYaml is used by Bukkit, it's up to them to keep it up to date.
     
  25. Offline

    Ablac

    What version of Java is your CentOS running?

    Cause we tested CentOS with Java and it worked, but my servers running OpenJDK and the Symbol isnt working.
     
Thread Status:
Not open for further replies.

Share This Page