Application RemoteToolkit - Restarts + crash detection + auto saves + remote console!

Discussion in 'Bukkit Tools' started by drdanick, Jan 16, 2011.

  1. Offline


    Minecraft RemoteToolkit
    -Less downtime, more fun for your players, more power to you!

    Are you a Minecraft server administrator? Do you value up-time and stability? Do you fancy the ability to remotely control your server, both in-game and out of game, in a myriad of useful ways from a plethora of different devices?
    If you answered yes to any of the above, then the Minecraft RemoteToolkit is for you!

    What the Minecraft RemoteToolkit Plugin and Wrapper do for you:
    • Provides almost perfect server uptime with no need for action from an owner/administrator!
    • Have your server save and restart at any time period with configurable restart warnings!
    • The Toolkit guarantees a restart within the set restart period, even if your server crashes, becomes unresponsive, or encounters a "SEVERE" exception!
    • Remotely control every function of the Toolkit, even from your smart phone!
    • Full remote console access via telnet with support for multiple terminal types!
    • Telnet daemon conforms to current Telnet related RFCs!
    • Customizable alert messages!
    • Fully extendable though 3rd party modules!
    • Full feature set works with most craftbukkit builds!
    • Most features work with any Minecraft server variation, even vanilla!
    • Telnet can be disabled!
    For server administrators
    Download - Release 10, Alpha 15.3 [CB 1.7.2-R0.2] (wget friendly)
    Instructions & Documentation

    For developers
    UDP API REV 8 | Documentation
    Module API | Coming soon!

    For everyone
    Official IRC channel
    #remotetoolkit @

    "Help! I've downloaded it, but I do not know how to get it working!"
    Stop! Before you give up or ask for help, make sure you have read the step-by-step installation instructions on the wiki page. If you are still having problems, please do not be hesitant to post a request for help on this thread or in the IRC channel - no matter how simple your problem seems.


    Any donation would be very much appreciated. I'm but a poor University student, and I sacrifice quite a lot of unpaid time to keep the Toolkit updates and support flowing.

    Thank you to the following who have chosen to support the Toolkit through a donation:
    Deren909, marshall007, Vittek, clanslots, meee, KyneSilverhide, szoller, hungoverfurball, Lama_0, Viet, acc1dent, joby890, Liger_XT5
    Last edited: Jul 28, 2015
  2. Offline


    someonexh I am intentionally leaving that for someone to implement as a module for R11. R10 is currently in a feature freeze.

    Check that UDP port 25561 is forwarded on your router, and that you do not have a firewall blocking UDP traffic to that port.

    This may be a lot to ask, but can you confirm that this happens without any plugins running, and also on a vanilla server run through the toolkit?

    In, set this:
    Code (Text):
    1. server-arguments=-nojline
  3. Offline


    No luck. still doing it

    First attempt at checking for presence of Bukkit RTK plugin...
  4. I can try it out on my Snapshot server for Vanilla.
    I'm sure I can try without any plugins on a test.

    Edit: Pardon my derp... My test server was using a very old build(1.0_b18_23)....... xD We'll see what happens lol.... *sorry*

    Hmm... Undo that edit. I'll get it testing with and without --nojline. It did it again, but this time it threw "RTPONG++" at the end of the line.
  5. Offline


    I just updated to MC 1.3.2 and started getting the same thing. It will try three times then disable itself until I restart the server.
  6. Offline


    I'm running it on port 25565.

    Does the remote UDP client have a separate port that I can't change?

    And plus, I portforwarded port 25561, addded a rule to the firewall, and i still get the same error. And, what should I set the "Salt" value to? AND my server is running on port 25565, should I enter <my IP address>:25565, or <my IP address>
  7. Hello all !
    I just had the problem of not finding the RTK plugin.
    But it was working fine before, so i know what i changed : i tried using bukkit beta build 1.3.2-R0.1 (to install NoLagg) instead of the latest recommended builds, 1.3.1-R2.0.
    Could you make it working with this version of bukkit ?
  8. drdanick

    The wipe just occurred on my Bukkit (1.3.2-R0.2 build 2352) with no plugins (besides your MinecraftRKitPluing.jar) with --nojline argument. Right after this occurred, " RTPONG++" popped up at the end as shown in the spoiler. It was running for about 2 hours and 30 minutes before it happened.

    Show Spoiler


    I haven't noticed this happening with Vanilla at all. I will now try without your plugin running on Bukkit to see what happens.
  9. Offline


    I get that all the time, it doesn't mess with the server.log file though, so it's not damaging.
  10. Could you possibly add color support?
  11. Offline


    is the restart option in the plugin, and not the .jar?
    i would prefer to keep using craftbukkit++, as it gives me much performance upgrades, but would also like the server to auto-restart.
  12. It seems like the RTKPlugin is not working with the latest Development Build of CB.
    This is what i do get :/
    Code (Text):
    1. 20:09:50 [INFO] [RemoteToolkitPlugin] Enabling RemoteToolkitPlugin v0.61
    2. 20:09:50 [INFO] Memory max: 1556938752 bytes
    3. 20:09:50 [INFO] Memory total: 1037959168 bytes
    4. 20:09:50 [INFO] Remote Toolkit Plugin V0.61 enabled!
    5. First attempt at checking for presence of Bukkit RTK plugin...
    6. Second attempt at checking for presence of Bukkit RTK plugin.
    7. Third attempt at checking for presence of Bukkit RTK plugin...
    8. RTK plugin for Bukkit was not detected. Disabling heartbeat until next restart.
    Server version:
    Code (Text):
    1. 20:00:58 [INFO] This server is running CraftBukkit version git-Bukkit-1.3.2-R0.1
    2. -4-gd08e620-b2359jnks (MC: 1.3.2) (Implementing API version 1.3.2-R0.2-SNAPSHOT)
  13. Offline


    This is somewhat broken since the 1.3.2 r0.1 update beta build, can't issue any commands, the RTK plugin cant be detected, long wait times on restarts and shutdowns. Gonna try the jline thing.
  14. Offline


    Also, this does not work.
  15. @drdanick

    If I don't have your plugin installed, this wipe does NOT occur.

  16. Offline


    Whoops, use this:
    Code (Text):
    1. server-arguments=--nojline
    Liger_XT5 Hartorn Lathanael Clackw3rk See above.

    Pythros I will look into it more carefully ASAP.
  17. drdanick
    What do you mean by "see above" ? Is it the thing with nojline ?
  18. Hmm seems i forgot another - in --nojline.

    Now it is working ;)
  19. Offline


  20. Ok, it works fine with this line.
  21. Offline


    I've been using your wrapper for a while, and now I'm getting some issues. Whenever the server automatically restarts, some of the chunks but not all of them are getting rolled back. I tried disabling all of my plugins except this and this seems to be the cause. I have scheduled restarts every 13 hours, and I run a quite big server, the world size is quite massive. It takes usually about 3-4 secs to do a /save-all command. I think there might be a problem with the time it allows the server to save the chunks after that the plugins sends a /stop command. Here's a log with for the shutdown period:

    I run tekkit 3.1.2 which runs a custom version of bukkit 1.2.5-R4. I would need help as soon as possible, thanks.
  22. Hey there, I've been using this for a long time, but suddenly I have some issues.

    First I was getting "RTPING>RTPONG++", so I put -nojline as a server argument (and the fact that I wasn't able to see what I was typing until after I hit Enter). But now, all the colors in the console have disappeared (and I really need these).

    I'm on 1.3.1R2.0. Thanks!
  23. I read the thread and the wiki page, but I still have a this plugin making it so the servers using it are hosted online, or is the "almost perfect server uptime" from the fact that you can feel safe using and viewing the console from anywhere you go?
  24. Offline


    Thanks people so much. --nojline Worked! Awesomee!
  25. drdanick likes this.
  26. Offline


    The command fixed the issue, and as stated previous posts, we see no color when viewing the console.
    I have my server hosted, so I have to use SSH to see the console. I've had issues reading chat when there is at least 5 people or more talking at once.
  27. Offline


    Everything working good here, using craftbukkit 2363. Well, except the console colors, but those never worked for me, since a year ago when I started using this.

  28. Offline


    When i start my server it runs fine with Remote Toolkit, but it gives an error every 5 secconds
    Code (Text):
    1. starting udp listen server on port *****
    2. There was an issue inding the UDP server to port ***** cannot assign requested address: cannot bind
    3. Attempting to refresh UDP server in 5 secconds...
    How do i get this to stop spamming my concole?
    Also, Every 8th time it replaces 5 secconds with 1 minute... Thanks
  29. Hey guys,
    I was using this plugin in 1.2.5 and it worked fine.
    I updated the plugin to 1.3.1. and so did I update the Survival Games plugin to 1.3.1. The server starts up and than it gives errors saying: Rtoolkit not found send impulse 1. etc.
    When I remove the survivalgames.jar rtoolkit works fine. It's just when I put the survivalgames.jar back in, it starts giving these errors again and players can't connect to the server when this happens.
    I updated this plugin just by copy & paste the new survivalgames.jar into my plugin folder. (Using mysql for storage).
    Can someone tell me how it fix this? And why are these plugins interrupting?
  30. Offline


    What are the permissions for restarting ingame and stuff
  31. Offline


    Received this error today:

    Code (Text):
    1. Exception in thread "stderr" java.lang.OutOfMemoryError: Java heap space
    2.         at com.drdanick.McRKit.Wrapper$
    Is this known at all? Couldn't find much looking around, but caused a random crash.

Share This Page