Received string length longer than maximum allowed (36 > 32)

Discussion in 'Bukkit Help' started by ProSkaterBoy96, Mar 2, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    ProSkaterBoy96

    20:19:24 [SEVERE] java.io.IOException: Received string length longer than maximum allowed (36 > 32)
    20:19:24 [SEVERE] at net.minecraft.server.Packet.a(Packet.java:120)
    20:19:24 [SEVERE] at net.minecraft.server.Packet2Handshake.a(SourceFile:17)
    20:19:24 [SEVERE] at net.minecraft.server.Packet.a(Packet.java:79)
    20:19:24 [SEVERE] at net.minecraft.server.NetworkManager.h(NetworkManager.java:149)
    20:19:24 [SEVERE] at net.minecraft.server.NetworkManager.c(NetworkManager.java:265)
    20:19:24 [SEVERE] at net.minecraft.server.NetworkReaderThread.run(SourceFile:76)

    What does this mean? And how can I fix it so people can log on?
     
  2. How much ram are you allocating you your server? Plugin List?
     
  3. Offline

    ProSkaterBoy96

    2Gb, and Chestshop, Essentials, Factions, LWC. Wiating for the rest to update. I wasnt getting it before I updated to 1.2
     
  4. Someone could have been trying to connect. I just read another post that had the same error when they were trying to connect. Not sure though as some of these errors I have never seen myself.
     
  5. Offline

    TnT Retired Staff

    This error you get when someone with a 1.2 client tries to log into a 1.1 server (at least as of b1940). I see it on my server console as well.
     
  6. I knew it! Sort of :p
     
  7. Offline

    SlaughterSlayer

    I get that error message, too!! Even though all my stuff is updated to 1.2.
     
  8. Offline

    Minecraft-Mania

    I also get that error on my console, and have everything updated. Could this possibly be a Bug in Bukkit itself?
     
  9. Offline

    Miles_

    I gt the same error. I even put "DO NOT USE 1.2, USE 1.1" in the motd but nobody listens... It would be useful if bukkit let you holes customs messages for different errors such as I you know that this error is because he client needs to be 1.1 then you could say that they need to use 1.1.
     
  10. Offline

    Fungreenfox

    I think it is related to bukkit Speak. I trype from TS3, works first time. Then it says same error and there is no output from TS3 to ingame chat.
     
  11. Guys, I wouldn't worry about this error unless it is causing major lag when it happens. I get it too because I have my server on 1.1 until there is either a beta or recommended build of CraftBukkit. It doesn't seem to affect much.
     
  12. Offline

    Tottely

    got the same guess that ppl using 1.2. If people got any brain they should know most of us hosters dont use 1.2.3 bukkit yet :)
     
  13. Me too, same error!
     
  14. Offline

    Darkintellect

    Having the same problem. I updated my server (which I've been running for months now) as well as minecraft.jar to 1.2.4 and played it last night with zero problems. I then log in today and I just now encountered the issue when tryng to login to the server...
    Code (Text):
    1. internal exception: java.io.ioexception: received string length longer than maximum allowed (121>119)
     
  15. Offline

    Fungreenfox

    I was online with the very first bukkit dev 1.2.4#2104 and the bug persisted until 1.2.4#2106 or so. My server is at #2116 now and running fine, no break down anymore. The bug with typing /pl, is solved by making pl to an alias for /list in bukkit.yml.
     
  16. Offline

    bomb557

    so how do i fix this issue? i started a LAN server off of my computer and im trying to play the yogbox off the 2.1.1 sever i downloaded from the tekkit site but i keep getting this error. any help would be appriciated thx
     
  17. Offline

    Lord_Hasu

    I was playing on a vanilla server, and this same thing happened to me.
    I just thought that was interesting
     
Thread Status:
Not open for further replies.

Share This Page