Players keep getting disconnected

Discussion in 'Bukkit Help' started by Wicstar, Feb 11, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Good day all,
    My players keeps getting disconnected from the server.

    Bukkit: 1.1 R3
    - LWC
    - Essentials
    - Choptree
    - LogBlock

    This is the error that comes up in the console before they get disconnected. Unfortunately, I dont get what are those source files number. It's always the same numbers by the way.
    Code (Text):
    2. [INFO] Read timed out
    3. [SEVERE] Socket closed
    4. [SEVERE]    at
    5. [SEVERE]    at
    6. [SEVERE]    at
    7. [SEVERE]    at
    8. [SEVERE]    at
    9. [SEVERE]    at
    10. 2012-02-10 17:46:29 [INFO] DarkWarrior727 lost connection: disconnect.endOfStream
    Anyone can help me here ? I am starting to lose my players :S
  2. Offline


    Seems like it's happening to alot of players find out where they live my server only kicks east coast players form this error.
  3. I been told its a problem with Minecraft, not Bukkit. Can a another Bukkerter confirm?
  4. Offline

    Donald Scott

    This doesn't necessarily mean anything. It could be a simple disconnect.
  5. Offline


    This is because your bandwith cant cope with all the connectios. You will need good internet download speed for this and uplaod speed
  6. Offline


    Well I am paying for the host ( it is suppose to accommodate 24 players... it crash if we are alone or 6 online haha !
  7. Offline


    Ask them there network specs, also if you live in the UK get
    They are the best
  8. Offline


    I live in Canada. Our server is in Chicago and always worked fine until 1.1 release.
  9. Offline


    Like i said ask what their Network specs are. Let me join server ok i will see what plugin is causing it
  10. Offline


    Found error. Get rid of logblock then you should be alright. Also how much ram is allocated on the server
  11. Offline


    Ya I don't believe this has anything to do with bandwith. I have been running my server with 60-80 people on it all the time and until 1.1.0 I have had no problems. My host is running a 100mb upload it's a 16gig xeon 3.4 quad dedicated server and I have 10tb's of bandwith to use monthly and don't come close. the cap is set to 1tb a day on the servers robot opitions. There's alot of post about this topic and no one really knows. Some say it's bukkit some say mojang some tried to say it's a plugin. I googled binged and checked all the forums I possibly could no one has a single answer.

    All my players get read timed out error only from the east coast like 10-20 or more players will just drop then can't connect back in 2-5mins alot of them say it's been happening on other servers they play on to so no idea. Just hope maybe with a 1.2.0 release this issue will be fixed through whatever is doing it. Because in 1.0.0 I had never had any issues with a read timed out at all.
  12. Offline


    Yeah I guess we will wait until then.
    I don't want to get rid of LogBlock as it was working fine before and it is a great tool against griefer
  13. Offline

    Nathan C

    Dude, this error means nothing and is basically normal.

    Happens all the time on my server and it is just someone disconnecting usually.
  14. Offline


    Those people are not disconnecting, they are being kicked. Which is why the error is popping.
  15. Offline

    Nathan C

    Nope, not for me. It happens because their internet crashes or something else wrong on the clients end.
  16. Offline


    I have beastnode and ever since 1.1 i've had the server randomly lag 3-5 seconds and start disconnecting players left and right. It reports no errors or overloaded messages during this time only a laundry list of disconnects. Then it will be fine.

    I've pulled my hair out disabling plugins, upgraded to more RAM, everything. Even talked to beastnode and they said i was the only one getting these problems.

    Btw, Wicstar i'm on the chicago node as well.

    It happened to me 3 times today alone.

    EDIT - 1.1-R4 is now out.
  17. I've had this error too and users think they're getting kicked, I'm 99% sure its a MineCraft bug.
  18. Offline


    I host a server with 1-10 players online all the time and sometimes this error pops up and kicks everyone.
    While they got kicked, the server freezes i think for about 20sec then we're able to join again.
    Happens pretty often now when i upgraded from R1 to 1.2.3 beta
Thread Status:
Not open for further replies.

Share This Page