[MISC] Dynmap v1.9.2 - Real-time Minecraft maps [1.4.7 through 1.7.2R0.3]

Discussion in 'Archived: Plugin Releases' started by Mike Primm, Jan 15, 2011.

  1. Offline

    Mike Primm

    My BukkitDev Profile
    My Plugins (13)
    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    *** AS I AM NOW SUPPORTING MORE THAN JUST BUKKIT WITH DYNMAP, THE MAIN SUPPORT THREAD IS NOW ON MINECRAFTFORUMS.NET - FOR QUICKEST SUPPORT, PLEASE BEGIN USING THIS THREAD ***

    For downloads of the latest Bukkit version, go to our dev.bukkit.org page.
    For downloads of the latest Forge versions, including for MCPC-Plus, go to our curseforge.org page.
     
  2. Offline

    Kainzo

    My BukkitDev Profile
    My Plugins (8)
    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Interesting - I will be checking into this.
     
  3. Offline

    xpansive

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I'm just getting a black screen...
     
  4. Offline

    FrozenCow

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Are you using the internal webserver (http://hostname:8123/).
    If so, have you placed some blocks in Minecraft to make Dynmap update those tiles of the map? If that does not help, do you see yourself online on that page when you are logged into your Minecraft server? If so, click on your name and you'll pan over to your characters location. See if you see some tiles there.
     
  5. Offline

    Octane

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    me tooo, just a black screen on my browser, i use firefox, but doubt that should do anything, it shows powered by google and everything just the screen is black however i have yet to go ingame and fool around, i will do that right now to makes sure thats not the problem

    odd, my server will no longer just stop when i type stop in the console of it..... not sure if thats related to any mods i have added,
     
  6. Offline

    FrozenCow

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Oops, I did not check for all browser compatiblity. At the moment it should work in Google Chrome, but I'm not yet sure about the others. I'll get on it.
    EDIT: Sigh, still problems with other problems.
     
  7. Offline

    Octane

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    OK this mod has problems, I put the .jar into my plugins the web folder in my main folder with the server and stuff, but THIS MOD is causing my server to lockup, what happens is i dig away a block, and then it allows me to receive its item or w/e for digging it up, i dig up another block, guess what? nothing, and withn 1 min i time out, and the dynmap when your logged in and watching it as you play (i have 2 monitors) it locks up no longer does it show my character movign even though i have moved like 1 km, before it times out, i have removed the dynmap.jar file from my plugins and my server is 100% fine no time outs no nothing, so somethings up with the mod, once oyu get it working it looks like its VERY useful!
     
  8. Offline

    FrozenCow

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    All features are (or rather will be after bugfixes) available in the basic internal server. I could do a little video for that, but doing a tutorial for each big webserver on each operating system would be too much work for me to handle ;).
    Yes, it does. But your problem does not seem to be happening here. Now that I think of it, I've updated my server to the latest Bukkit from Github, maybe it has something to do with that. I'll first fix the browser compatibility issues and get back to this issue after that.
     
  9. Offline

    JaredKey

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I know you've replied to the issues but I just wanted to confirm that I'm also only getting the black screen. Good luck!
     
  10. Offline

    Octane

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    well, im using firefox, heres the mods i have and when i remove dynamap from my plugins the server runs fine, i have, my home. my warp. minecartmania core. so thats all i have, i have the latest bukkit which is craftbukkit 14
     
  11. Offline

    JaredKey

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Also, everytime I placed a block, the server posted "invalidating block" and would remove it shortly after it was placed.

    Mods:
    General
    Healthy
    Minecart
    Mywarp
    Vanish
    Worldedit

    Latest bukkit and craftbukkit as of 1/14 8:00pm Eastern.
     
  12. Offline

    FrozenCow

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Thanks!
    Yes, I've seen the problems in combination with Firefox. Again: oops. I'll mark this thread as 'unstable version' for less confusion ;).
    Thanks for the information. First thing I'll do is log (more) errors once an error occurs and hopefully see some of them myself.
     
  13. Offline

    TheYellowAnt

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Using Google Chrome.

    The mod would not generate tile PNGs until I ran Bukkit with Administrator privileges. When it did create tiles it put them in the 'tiles' folder under the bukkit folder, not the 'plugins/web/tiles' folder. Even when I copied the created tile into the latter folder it did not appear on the web server map.

    I was able to place blocks into the world to trigger the tile generation, but I was not able to destroy blocks. They would break but not drop and then would reappear in a second or two.

    I hope this is useful!
     
  14. Offline

    Octane

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    its not firefox, i dont even connect on my web browser, and i do what i said i do and it freezes up and after a min saying it times out and crap and so on
     
  15. Offline

    FrozenCow

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    For people having trouble with black screen, I've uploaded a new version with browser compatibilities fixed.
    Thanks for the information, that is indeed helpful.
    You should not move the tiles folder, it is placed right (in minecraft_server/tiles/, though, this will likely change in the future). Also extracting the `web` folder should not be needed, but doesn't do much harm. Have you really checked if the tiles showed up on the map when they were in the original tiles folder? If they did not, did you see your name in the top-right?
    As for the administrator privileges, is Bukkit in the same folder as the minecraft-worlds? It seems strange that minecraft can write the world-files, but the plugin cannot write to the tiles-folder. Maybe putting Bukkit/Minecraft not in Program Files (or something alike), but in `My Documents` might help for that. (I know that sounds stupid, but you can also try to change rights on the folder of bukkit)
     
  16. Offline

    TheYellowAnt

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Bukkit lives in a folder on my desktop. (This is Windows 7 64-bit, btw.) The bukkit jar is in the same folder with minecraft_server.jar and a world folder. I'm running the latest craftbukkit release.

    My name does show up in the map while I am logged in, and I can center the map on me by checking the box, but the map tile does not show up.
     
  17. Offline

    Solaris765

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    hello. i've tried setting up the hey0 version failed then found this. so far i thin i have everything working except for one thing unless all this is unnecessary.

    anyway the trouble i'm having is this. in terminal i get the message: dynmap:
    request: /up/undefined
    dynmap: Sending 0 players and 0 tile-updates. /undefined;0
     
  18. Offline

    TheYellowAnt

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    It appears like the first object I place into the world gets stuck; I can destroy it but it reappears. And any item I place after that won't stay in the world; it disappears when the map refresh happens. After a minute or so I get a Connection Lost Timed Out error.

    If I had to guess I'd say something you're doing is interfering with the client communicating changes to the server. Good luck! Let me know if I can experiment or test anything for you.
     
  19. Offline

    FrozenCow

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I've had this problem with Firefox, but fixed the incompatibility in the latest version (0.01). Could you try that version?
     
  20. Offline

    Solaris765

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    oh great! thanks alot! that fixed it.
    Edit: fail my user name came up but it won't update the map
    now its sending me this:
    dynmap: request: /up/1295057915
    dynmap: Sending 1 players and 0 tile-updates. /1295057917;1295057917000

    don't really know if its supposed to do that but hey thought i'd through it in
     
  21. Offline

    FrozenCow

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Yes, that was my thought too. I have updated the version that could fix the issue, but i'm not sure, can't seem to reproduce. In any case, I've added more error messages where they could be useful. Also, I saw that Dinnerbone made two fixes to block placement in CraftBukkit 5/6 hours ago, which is the version I've been using since the patch. Are you using this version too?
    --- merged: Jan 15, 2011 2:36 AM ---
    Versions are flying. This was again an 'oops' moment. The latest version (0.02) should work (more ;)) for you now.
    --- merged: Jan 15, 2011 2:39 AM ---
    You should also try version 0.02, since you're having the same issue... and I'm guessing everyone else should try this version too. It was a really stupid 'bug', which could also have caused Minecraft being shut down because of the error it raised.
    *Taking a nap...
     
  22. Offline

    Solaris765

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    with version 0.02 i still seem to be having the same issue.
    would it help to know i am running this on mac osx snow leopard?
     
  23. Offline

    DDRKhat

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    I can get the webpage loading fine. I can run around fine and the map will update to show me.
    But if I place a block/pickup objects or anything, this plugin kills my server.
     
  24. Offline

    TheYellowAnt

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    "Chunk was not loaded, but we'll still continue to render." Then a minute later I disconnect with the "Connection Lost Timed Out" error. I'm using Build #15 of Craftbukkit.

    The map now displays the one tile PNG that is in the tiles folder. Improvement!
     
  25. Offline

    varpness

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Okay, just to clarify, do we extract the map folder anywhere? If not, then why is the map folder included in the download? I'm having the same problem as others have reported. No tiles are updated.

    EDIT: Nevermind about the map folder question. I see that the jar contains the same folder. I'm not sure why it's in the download package.

    The readme says something about editing a map.js file. Could someone please clarify this information?
     
  26. Offline

    Nipper

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Maybe a idea. I'm not a fan of the auto map rendering so maybe is there a way to type in a command like /redrawdynmap and have it render it all that I can do every so often.. or make stand alone command via console to do it.
     
  27. Offline

    Stribbs

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    That kind of defeats the purpose of dynmap. If you want a mapper that you can run periodically. There's plenty of options for you.
     
  28. Offline

    Aubron

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Running Linux server on 64 bit Ubuntu.

    Installs fine, server runs fine, can connect and see self as yellow dot on the map. However, upon the first block placement/removal CPU usage spikes and all further block placements and removals are ignored, followed by client disconnect. Also, cannot end server with "stop" command to console, and have to kill the process to stop the server.

    EDIT: To be clear, none of the tiles ever render for me, just black screen with yellow dot.
     
  29. Offline

    Acidnine

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    With Build 19 of CraftBukkit and the latest Dynamic Map (1/15/11 12:20AM) I'm getting this:

    Code (Text):
    1. 2011-01-15 00:21:08 [INFO] dynmap: invalidating tile t_-128_128
    2.  
    3. 2011-01-15 00:21:08 [INFO] dynmap: invalidating tile ct_-128_128
    4.  
    5. 2011-01-15 00:21:08 [INFO] dynmap: invalidating tile t_-128_128
    6.  
    7. 2011-01-15 00:21:08 [INFO] dynmap: invalidating tile ct_-128_128
    8.  
    9. 2011-01-15 00:21:09 [INFO] dynmap: rendering tile t_-128_128_-128_128...
    10.  
    11. 2011-01-15 00:21:09 [INFO] dynmap: rendering tile t_-128_128_-128_128...
    12.  
    13. 2011-01-15 00:21:09 [INFO] dynmap: Chunk was not loaded, but we'll still continu
    14.  
    15. e render.
    16.  
    17. 2011-01-15 00:21:09 [INFO] dynmap: Chunk was not loaded, but we'll still continu
    18.  
    19. e render.
    Basically the same problem TheYellowAnt was describing. After removing 1 block the server immediately becomes unresponsive to any commands, animals freeze, all blocks removed from will disappear then reappear after a few seconds, and land stops regenerating/displaying (although sun/moon keep moving) and then soon a connection timeout will occur (if you're lucky you can make it to the edge of the map and jump off into infinity ;)

    Good Luck! Thanks for your hard work on this.
     
  30. Offline

    chardo440

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Why does it say oops, link appears to be broken when clicking on the yourminecraftserver link you have posted I've copied the .jar into the plugins started the server over again and I've logged in but I get that error message what did I do wrong haha. Thanks ahead for the help.


    Update: I've clicked index.html and I now have a black screen but it pretty much makes my server stop working.
     
    iPhysX and joby890 like this.

Share This Page