[INACTIVE][FIX/SEC] AntiHack v2.1 - Blocks bugs, cheats and hacks! [953]

Discussion in 'Inactive/Unsupported Plugins' started by robin0van0der0v, Mar 20, 2011.

  1. Offline

    robin0van0der0v

    AntiHack - Blocks bugs, cheats and hacks!
    Version: v2.1

    Features:
    • Blocks interacting with blocks on a invalid location.
    • Blocks flying.
    • Blocks unknown items.
    • Blocks interacting with blocks/entities too far away.
    • Blocks infinity items.
    • Logs every violation.
    Download AntiHack!
    Source is inside the jar file.

    Permissions:
    Give the player you want this permissions for being an exempt to the block invalid location checking:
    Code (Text):
    1. antihack.canblockinvalidlocation
    Give the player you want this permissions for being an exempt to the flying checking:
    Code (Text):
    1. antihack.canfly
    Give the player you want this permissions for being an exempt to the unknown item checking:
    Code (Text):
    1. antihack.canunknownitem
    Give the player you want this permissions for being an exempt to the too far checking:
    Code (Text):
    1. antihack.cantoofar
    Give the player you want this permissions for being an exempt to the infinity item checking:
    Code (Text):
    1. antihack.caninfinityitem
    Known bugs:
    You can't walk on half blocks.
    You can fly above layer 128.

    Properties:
    This plugin creates a properties file on Plugins/AntiHack/config.yml. ;)

    Standard properties:
    Code (Text):
    1. antihack:
    2.     blockinvalidlocation:
    3.         check: true
    4.         log: true
    5.     fly:
    6.         check: true
    7.         log: true
    8.     unknownitem:
    9.         check: true
    10.         log: true
    11.     toofar:
    12.         check: true
    13.         log: true
    14.     infinityitem:
    15.         check: true
    16.         log: true
    Changelog:
    Version 1.0
    • Release.
    Version 1.1
    • Added block for interacting with blocks to far away.
    Version 1.2
    • Added logging.
    Version 1.3
    • Works in Beta 1.4.
    Version 1.4
    • Fixed BLOCK_IGNITE NullPointerException.
    Version 1.5
    • Blocks fly mods.
    • Fixed door-cactus bug.
    Version 1.6
    • Added Permissions node for flying.
    • Fixed walking over slabs.
    • Fixed triple-chest bug.
    • Fixed placing cacti in ground.
    • Limited console messages for flying.
    Version 1.7
    • Blocks unknown items.
    • Blocks infinity items.
    Version 1.8
    • Fixed NullPointerException on reload.
    Version 1.9
    • Removed fix for door-cactus bug because this is fixed in 1.6.
    • Removed fix for triple-chest bug because this is fixed in 1.6.
    • Removed fix for placing cacti in ground because this is fixed in 1.6.
    Version 2.0
    • Now really blocks fly hacking, not just a message.
    Version 2.1
    • Added configuration file.
    • Added more Permission nodes.
    • You can no longer fly above layer 128.
     
  2. Offline

    OlDrunk

    Just a bug I noticed , when getting out of boats next to land it detects it as flying , it's easy to work around but figure I'd make note of it.
    Great plugin and thanks to the Dev!
     
  3. Offline

    robin0van0der0v

    Fixed. :)
     
  4. Offline

    Master_Digi

    i have a problem i can't use a minecart the server say's i fly but the problem is only on a bridge

    sry for my bad english
     
  5. Offline

    bleepbleep

    how do i let myself fly and others can't where do i put antihack.canfly at and how should it be put like please help :)
     
  6. Offline

    FXStrato

    Does this work with CB740?
     
  7. Offline

    Kahl

    I am wondering this too.

    Anyone using on 740?
     
  8. Offline

    FXStrato

    I tried it, and for some reason, it can't seem to pass the PLAYER_MOVE to Antihack.
     
  9. Offline

    padakoys

    the link is dead :/
     
  10. Offline

    lolzrofl

    When someone with fly permissions flies, my console gets spammed with this
    Code (Text):
    1. :Could not pass event PLAYER_MOVE to AntiHack
    2. :Could not pass event PLAYER_MOVE to AntiHack
    3. :Could not pass event PLAYER_MOVE to AntiHack
    4. :Could not pass event PLAYER_MOVE to AntiHack
    5. :Could not pass event PLAYER_MOVE to AntiHack
    6. (and like 100 times more)
     
  11. Offline

    Rowtag

    Link is Broken, please reup :)

    Does it work with 740? :)
     
  12. Offline

    homerbond005

    can't download it.
     
  13. Offline

    tassox33

    the link is broken
     
  14. link is STILL broken :'(
     
  15. Offline

    maetthew

    Link broken for me too
     
  16. Offline

    Shuan

    oh my god this is such an amazing plugin i...... THE LINK OMG THE LINK WHY IS IT NOT WORKING *TEARS HIS SHIRT APART* WHYYYYYYYYYYYYYYYYYYYYYY Oh...

    Well you should make the link fix a little more obvious than what you have, or just update the hyper link? Man im smart what a great idea
    Let me do it for you ANTIHACK PLUGIN 1.6 YAY!
     
  17. Offline

    link2110

    Quick request/question. Is it possible to just have a few of blocked hacks? I already have NoCheat for flying, speedhacking, airbuilding, and building too far away, and AntixRay for xray, All i really need is door cacti bug and triple chests blocked and i have blocked 99% of the hacks used by most people. :D
     
  18. Offline

    Niles

    I have am an admin on my server, I have permissions '*' yet it still kicks me for moving too fast when I use my fly mod. Is there a way to turn this off?
     
  19. Offline

    Pyraah

    Good plugin. But can you to generate the alerts in an external file ?

    (sorry for my english, i'm french)
     
  20. Offline

    Martijn.

    In your normal server file you must set flying to true i think so you can fly but with this plugin also installed you can set who can and who can't fly
     
  21. Offline

    Elmegaard

    I think the link is broken.
     
    virtualism likes this.
  22. Offline

    MadcowD

    Broken Link
     
  23. Offline

    joby890

    this plugin love the antifly
     
  24. Offline

    GeekPlaya

    Confirmed not to work with 815 or 814. Please fix this! It produces log in the console such as not being able to read the PLAYER_MOVE event.
     
  25. Offline

    woodzy

  26. Offline

    robin0van0der0v

    I can't fix errors if I don't have the error. ;)

    If you don't give them acces to a give or item command, they cannot use it. ;)
     
  27. Offline

    woodzy

    If you don't give them acces to a give or item command, they cannot use it. ;)[/quote]
    thay DONT have access trust me
    noone is allowed to spawn shit on my server. an admin dont even have access to any give command's i dubble checked my permissions and thay dont have access. i have NO plugins that have any kind of "give" command only OP's can ban and such, but this will work nicly with CB#815 (minecraft 1.6.4)
     
  28. Offline

    lolzrofl

    Does this work with #818?
     
  29. Offline

    acetech09

    yeah - 818 compatibility?

    oh and perhaps you can add permissions for all hack things that are blocked, not just flying... so I can still use my super awesome reach mod but my lowly members cant :).
     
  30. Offline

    Pyraah

    Hi, i've an error :
     
  31. Offline

    robin0van0der0v

    Fixed. :)
     

Share This Page