Friends cant connect to server?

Discussion in 'Bukkit Help' started by Edolas, Dec 17, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    Edolas

    Hello , im new to this whole Minecraft stuff and ive just recently started playing minecraft, ive made a Bukkit server for 64-bit computer and currently working. However the problem is my friends cant connect but i can? :( Im using Hamachi and they've joined the network and the server on minecraft 1.0.0. . Here's some info on my server.

    When i run the cmd.
    174 recipes
    27 achievements
    00:22:30 [INFO] Starting minecraft server version 1.0.0
    00:22:30 [INFO] Loading properties
    00:22:30 [INFO] Starting Minecraft server on (HAMACHI IP):25565
    00:22:30 [WARNING] **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!
    00:22:30 [WARNING] The server will make no attempt to authenticate usernames. Be
    ware.
    00:22:30 [WARNING] While this makes the game possible to play without internet a
    ccess, it also opens up the ability for hackers to connect with any username the
    y choose.
    00:22:30 [WARNING] To change this, set "online-mode" to "true" in the server.set
    tings file.
    00:22:30 [INFO] This server is running Craftbukkit version git-Bukkit-1.8.1-R4-1
    7-g04a14f7-b1493jnks (MC: 1.0.0) (Implementing API version 1.0.0-R1-SNAPSHOT)
    00:22:30 [INFO] Preparing level "Edolas"
    00:22:30 [INFO] Default game type: 0
    00:22:31 [INFO] Preparing start region for level 0 (Seed: -9117650264014725773)
    00:22:32 [INFO] Preparing spawn area: 77%
    00:22:32 [INFO] Preparing start region for level 1 (Seed: -9117650264014725773)
    00:22:33 [INFO] Preparing spawn area: 93%
    00:22:33 [INFO] Preparing start region for level 2 (Seed: -9117650264014725773)
    00:22:34 [INFO] Preparing spawn area: 97%
    00:22:34 [INFO] Server permissions file permissions.yml is empty, ignoring it
    00:22:34 [INFO] Done (0.324s)! For help, type "help" or "?"
    >

    Server Properties

    #Minecraft server properties
    #Thu Dec 15 16:17:50 GMT 2011
    allow-nether=true
    level-name=Edolas
    allow-flight=false
    enable-query=false
    server-port=25565
    enable-rcon=false
    level-seed=
    server-ip=(Hamachi IP) < Normally my Hamachi ip is there
    white-list=false < Has this got anything to do with it?
    spawn-animals=true
    online-mode=false
    pvp=true
    difficulty=1
    gamemode=0
    max-players=20
    spawn-monsters=true
    view-distance=10
    motd= Edolas Beta Pvp Survival

    If you can comment or pm me how to fix this it would be very useful since im a newby to this stuff :p
     
  2. Offline

    ksisniper47

    Your online mode is false, set it to true and they should be able to connect. Make sure the port 25565 is port forwarded also.
     
  3. Offline

    Edolas

    Im using the cracked/illegal version of minecraft i heard that your not supposed to put it on and i thought i dont need to port forward since im using hamachi?
     
  4. Offline

    p0p3y3Z

    Offline mode is so Legit and Non-legit players can play together as well. I don't recommend talking about pirated versions of the game here. Try running it as an administrator. Also try turning whitelist on and adding them to it. What is the exact error they get?
     
  5. Offline

    Edolas

    My friend isnt on atm but i remember its somit like Can't Reach server after they add the server.
     
  6. Offline

    p0p3y3Z

    Uh, i remember that for some reason when my friend hosted his MC server, it wouldn't let me connect if I Maximized the window for minecraft. So tell them to start MC, DONT Maximize the window, connect, and if it works, then maximize it. Weird fix for that problem. Good Luck!
     
  7. Is hamachi allowed in your firewall?
    zip
     
  8. Offline

    Edolas

    Ill try that.

    Wasnt in my firewall program list. So wasnt allowed or blocked.
     
  9. ok, hope you can figure it out =)
     
    Edolas likes this.
  10. Offline

    Edolas

    Ive done all this but it says Cant reach server for my friend.
     
  11. Offline

    mindless728

    keep server-ip empty, there is no need to set that at all
     
  12. Offline

    Edolas

    Ive done that, my friend still cant join. Error is Cant Reach Server but i can

    #Minecraft server properties
    #Thu Dec 15 16:17:50 GMT 2011
    allow-nether=true
    level-name=Edolas
    allow-flight=false
    enable-query=false
    server-port=25565
    enable-rcon=false
    level-seed=
    server-ip=
    white-list=true
    spawn-animals=true
    online-mode=false
    pvp=true
    difficulty=1
    gamemode=0
    max-players=20
    spawn-monsters=true
    view-distance=10
    motd= A Minecraft Server
     
  13. Offline

    Edolas

    Anyone can help ><? Got Skype/T.V
     
  14. Offline

    Edolas

    Bump~
     
  15. Offline

    Zynastor

    You can't port forward?
     
  16. Offline

    Edolas

    I dont wanna,heard that it can affect your internet speed
     
  17. Offline

    Zynastor

    @Edolas True. But I had the same problem, I just portforwarded. Plus you or your friends can also connect using your Hamachi IP. Not only that, but you can use localhost to connect and play with your friends as well. BTW, it's Batch, not CMD.
     
  18. Offline

    Edolas

    Im using hamachi atm but seems they cant join and dont know how to use localhost.
     
  19. Offline

    TnT Retired Staff

    I feel you misunderstand how port forwarding works. Port forwarding wouldn't slow you down anymore than Hamachi would.
     
    waxdt and zipron like this.
  20. Offline

    Zynastor

    @TnT Thanks for backing me up, bro. :D
     
Thread Status:
Not open for further replies.

Share This Page