Inactive [ECON] iConomy 6.0.7 (Celty) [1337]

Discussion in 'Inactive/Unsupported Plugins' started by Nijikokun, Jan 3, 2011.

  1. Offline


  2. Ok now this is annoying, You have no legit wiki from what I can see, No legit instructions on how to switch from iConomy 5 to 6 You forgot about the users who use all different settings! I mean if you are planning on doing a major update at least min think of all routes to being changed this is so unprofessional and annoying! Not only me but other users are having issues! I cant even find a tutorial on how to switch my h2.db file your new system. I follow the .yml instuctions and nothing quit frankly I am getting fed up and getting pushed away from this plugin and I am sure others are as well.!

    Keep receiving this error after follow the shit instructions that makes little sense!

    Code (Text):
    1. 2011-09-24 07:37:57 [INFO] [iConomy] Database Error: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure
    3. The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
    4. 2011-09-24 07:37:57 [INFO] [iConomy - Celty] Enabled (4 s)
    Easy converter my a**
    Regulus123 likes this.
  3. Offline


    same issue for me =/ same happens for mysql and h2 and i wish to use mysql
  4. Offline


    i can't use mysql
  5. Offline


    Hi there! I have set on our server a "visitor" class. I'd like iConomy to avoid giving them the initial money it gives to my players. Is there a way to make iConomy not grant money to them? I only found permissions about command lines for interacting with the plugin (like /money), not about the plugin's behaviour in itself and with who it should work or not.
    Thanks a lot!
  6. Offline


    Having a problem with getting iconomy permissions to work on Groupmanager. Using latest bukkit RB, and latest of each plugin.
    I enter the permission nodes under
    of each group and when i attempt to use /money or anything it says
    "Bukkit is sad, bukkit would like to let you access this command, blah blah will leak tears".
    Does anyone know how to get it working with groupmanager? I have zero problems getting it to work with the regular bukkitpermissions but need to get it working on groupmanager.
    Thanks in advance.
  7. Offline


    You should use a plugin called "Pay Day" to do this.
    Heres a link to the plugin:

    With the 1.8.1 update of essentials, iConomy no longer works properly. You will need to wait until they resolve the conflict.

    iConomy 6 is partially in beta it seems, its not completely working, but some people can get it to work. It would be best if you stayed with iConomy 5 until the vast majority of plugins updated their payment systems from iConomy 5 to iConomy 6.

    It has been replaced by the iConomy 6 page. If you need to download iConomy 5.01 here is a link:
    Also, if you need permission nodes, here is the documentation for them:

    Here are the permission nodes:

    You download a .zip file from here, then use a program called WinRAR or Winzip to unzip the file. Inside of the .zip file you will find the .jar file and the folder/files needed for the plugin (config, ect.)

    Here is a link to iConomy 5.01

    Stop getting mad at the plugin developer, just because it isn't COMPLETELY documented properly doesn't mean that you have any right to be mean or ungrateful. Remember, these developers don't have to do ANYTHING for this plugin if they chose not to. It is because they WANT to help and make a good plugin that they do it. So don't bash the plugin developers, ask nicely, you are more likely to receive help that way.
  8. Offline


    Thanks so much!
  9. Offline


    Love your plugin.

    When will the release for buid #1185 come out?
  10. Offline



    MySQL DB is set correctly, it worked fine in 1.7.3, any ideas?
  11. Offline


    For me personally, absolutely nothing seems to happen when trying to upgrade with MySQL. It is definitely able to connect to the database because I can generate a table from scratch (and even read most of the old data since the only column that changed is the hidden column).

    But simply nothing happens when I set Conversion.Enabled to true and input the same database info as the main connection. It turns on, says iConomy is online, and nothing changes.
  12. Offline


    Economy isn't adding money from MoneyDrop and isn't taking away money.
  13. Offline


    Permissions work sometimes, but some aren't working. Like people can't pay but they can see their money.
  14. Offline


    Try changing it to jdbc:mysql:\\localhost:3306\minecraft
  15. Offline


    HELP! errors when ever someone joins.
    Code (Text):
    1. 161 recipes
    2. 17 achievements
    3. 17:23:40 [INFO] Starting minecraft server version Beta 1.8.1
    4. 17:23:40 [INFO] Loading properties
    5. 17:23:40 [INFO] Starting Minecraft server on *:25565
    6. 17:23:40 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-1067
    7. -g6301507-b1185jnks (MC: 1.8.1)
    8. 17:23:40 [SEVERE] Could not load 'plugins\Guard.jar' in folder 'plugins':
    9. Jar does not contain plugin.yml
    10.         at
    11. ava:64)
    12.         at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    13. java:213)
    14.         at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    15. .java:136)
    16.         at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    17.         at org.bukkit.craftbukkit.CraftServer.<init>(
    18.         at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    20.         at net.minecraft.server.MinecraftServer.init(
    21.         at
    22.         at
    23. 17:23:41 [INFO] [SuperpermBridge] Superperm/Permissions bridge initialized
    24. 17:23:41 [SEVERE] Could not load 'plugins\Trader.jar' in folder 'plugins':
    25. Jar does not contain plugin.yml
    26.         at
    27. ava:64)
    28.         at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    29. java:213)
    30.         at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    31. .java:136)
    32.         at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    33.         at org.bukkit.craftbukkit.CraftServer.<init>(
    34.         at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
    36.         at net.minecraft.server.MinecraftServer.init(
    37.         at
    38.         at
    39. 17:23:41 [INFO] LWC: Loading shared objects
    40. 17:23:41 [INFO] LWC: Protection cache: 0/10000
    41. 17:23:41 [INFO] LWC: Native library: plugins/LWC/lib/native/Windows/x86/sqlitejd
    42. bc.dll
    43. 17:23:41 [INFO] [Safe Creeper] Safe Creeper V0.3.2 Enabled
    44. 17:23:41 [INFO] Preparing level "argos"
    45. 17:23:41 [INFO] Default game type: 0
    46. 17:23:41 [INFO] Preparing start region for level 0 (Seed: 1938268956)
    47. 17:23:42 [INFO] AppleTree v0.6 activated.
    48. 17:23:42 [INFO] [Bandages] Found Permissions Plugin!
    49. 17:23:42 [INFO] [Bandages] Enabled! Version:1.2.4 by bekvon
    50. 17:23:42 [INFO] BorderGuard version 4.11 is enabled!
    51. 17:23:42 [INFO] [CombatTag] Operational.
    52. 17:23:42 [INFO] [CombatTag] 2.9 Detected existing config file and loading.
    53. 17:23:42 [INFO] CommandBook 154-b6dca7c enabled.
    54. 17:23:42 [WARNING] CommandBook: 0 Warps(s) loaded
    55. 17:23:42 [WARNING] CommandBook: 9 Homes(s) loaded
    56. 17:23:42 [INFO] CommandBook: Maximum wrapper compatibility is enabled. Some feat
    57. ures have been disabled to be compatible with poorly written server wrappers.
    58. 17:23:42 [INFO] CommandBook: 0 banned name(s) loaded.
    59. 17:23:42 [INFO] CommandBook: 1 kit(s) loaded.
    60. 17:23:42 [INFO] CommandBook: Using the Bukkit Permissions API.
    61. 17:23:42 [INFO] [FireLord] 0.6.2 using Permissions system
    62. 17:23:42 [INFO] [FireLord] version 0.6.2 enabled!
    63. 17:23:42 [INFO] [Giant Trees] version 0.3.3 is enabled
    64. 17:23:42 [INFO] [HeroicDeath] 1.9.1 enabled.
    65. 17:23:42 [INFO] [HeroSpawn] Permissions system detected!
    66. 17:23:42 [INFO] [HeroSpawn] Version 0.2 Enabled
    67. 17:23:42 [INFO] [iChat] Permissions not found, Checking for GroupManager.
    68. 17:23:42 [INFO] iChat (v2.4.0) enabled
    69. 17:23:43 [INFO] [iConomy] Database Error: java.sql.SQLException: No suitable dri
    70. ver found for jdbc:mysql:\\localhost:3306\iConomy
    71. 17:23:43 [INFO] [iConomy - Celty] Enabled (34 ms)
    72. 17:23:43 [INFO] LavaFurnace loaded: 0 Furnace(s)
    73. 17:23:43 [INFO] LavaFurnace loaded: 0 User(s)
    74. 17:23:43 [INFO] LavaFurnace config file finished loading...
    75. 17:23:43 [INFO] LavaFurnace: Permissions detected, LavaFurnace permissions enabl
    76. ed...
    77. 17:23:43 [INFO] LavaFurnace version 1.4 is enabled!
    78. 17:23:43 [INFO] [mxAntiPVPCheat] Started
    79. 17:23:43 [INFO] [NoCheat] version [2.01] is enabled.
    80. 17:23:43 [INFO] NSCommand 0.2 enabled.
    81. 17:23:43 [INFO] [ServerSave] Save interval is: 3600 seconds.
    82. 17:23:43 [INFO] [ServerSave] ServerSave enabled!
    83. 17:23:43 [INFO] [SuperpermBridge] Superperm/Permissions bridge enabled
    84. 17:23:43 [INFO] WorldEdit 278-dd358bc enabled.
    85. 17:23:43 [INFO] WorldEdit: Using the Bukkit Permissions API.
    86. 17:23:43 [INFO] WorldGuard: Using the Bukkit Permissions API.
    87. 17:23:43 [INFO] WorldGuard: (argos) Single session is enforced.
    88. 17:23:43 [INFO] WorldGuard: (argos) TNT ignition is PERMITTED.
    89. 17:23:43 [INFO] WorldGuard: (argos) Lighters are PERMITTED.
    90. 17:23:43 [INFO] WorldGuard: (argos) Lava fire is blocked.
    91. 17:23:43 [INFO] WorldGuard: (argos) Fire spread is UNRESTRICTED.
    92. 17:23:43 [INFO] WorldGuard: Loaded configuration for world 'argos"
    93. 17:23:43 [INFO] WorldGuard: 2 regions loaded for 'argos'
    94. 17:23:43 [INFO] WorldGuard 5.2.3-SNAPSHOT enabled.
    95. 17:23:43 [INFO] [Citizens] NPC types loaded: trader
    96. 17:23:43 [INFO] [Citizens] Hooked into PermissionsBukkit.
    97. 17:23:43 [INFO] [Citizens] version [devBuild-177] loaded.
    98. 17:23:43 [INFO] [Citizens] Economy plugin found (iConomy, version 6)
    99. 17:23:44 [INFO] LWC: Loaded 137 locale strings (0 overrides)
    100. 17:23:44 [INFO] LWC: Permissions API: BukkitPermissions
    101. 17:23:44 [INFO] LWC: Currency API: iConomy6Currency
    102. 17:23:44 [INFO] LWC: Loading SQLite
    103. 17:23:44 [INFO] LWC: Using: Native
    104. 17:23:44 [INFO] LWC: Precached 197 protections.
    105. 17:23:44 [INFO] LWC: At version: 3.53 (b294)
    106. 17:23:44 [INFO] [mcMMO] Permissions version 2.7.7 found, using Permissions.
    107. 17:23:44 [INFO] Loading Config File...
    108. 17:23:45 [INFO] [mcMMO] Permissions version 2.7.7 found, using Permissions.
    109. 17:23:45 [INFO] mcMMO version 1.1.14 is enabled!
    110. 17:23:45 [INFO] mcMMO is keeping usage stats an. To opt-out for whatever bizarre
    111.  reason, check plugins/stats.
    112. 17:23:46 [INFO] PermissionsBukkit v1.2 is now enabled
    113. 17:23:46 [INFO] [Towny] Database: [Load] flatfile [Save] flatfile
    114. 17:23:46 [WARNING] [Towny] Error: Towny does not have native support for iConomy
    115.  6.0.6b. You need the Register.jar.
    116. 17:23:46 [INFO] [Towny] Using: Permissions
    117. 17:23:46 [INFO] [Towny] Time until a New Day: 2 hours, 36 minutes, 13 second
    118. 17:23:46 [INFO] [Towny] Version: - Mod Enabled
    119. 17:23:47 [INFO] [VanishNoPickup] 1.9.12+essentials2 enabled.
    120. 17:23:47 [INFO] Server permissions file permissions.yml is empty, ignoring it
    121. 17:23:47 [INFO] Done (0.611s)! For help, type "help" or "?"
    122. 17:23:48 [INFO] [Citizens] Loaded 13 NPCs.
    123. 17:23:48 [INFO] New max size: 484
    124. 17:23:48 [INFO] New max size: 784
    125. 17:23:48 [INFO] / lost connection
    126. 17:23:51 [INFO] HSBox [/] logged in with entity id 98 at ([ar
    127. gos] -22.066360507567502, 71.0, 24.727939039357693)
    128. 17:23:51 [INFO] [iConomy] Database Error: java.sql.SQLException: invalid databas
    129. e address: jdbc:mysql:\\localhost:3306\iConomy
    130. 17:23:51 [INFO] [iConomy] Database Error: java.sql.SQLException: invalid databas
    131. e address: jdbc:mysql:\\localhost:3306\iConomy
    132. 17:23:51 [INFO] [iConomy] Database Error: java.sql.SQLException: invalid databas
    133. e address: jdbc:mysql:\\localhost:3306\iConomy
    Please help!
  16. Not sure if it's a bug or whatever..
    If I were to send "exampledude127" some money, it says to him, for example: "exampledude127 sent you money".
    Now this is very weird, since it looks like your receiving money from yourself. Is it a bug or a bad feature?
  17. Offline


    You'll have to change your database settings in the config or change to flatfile saving.
    your're using the default mysql IP, it can't work like that

    I'm pretty sure it's a bug. I'm having the same problem.
  18. Offline


    why? 0.0
    2011-09-24 22:58:25 [SEVERE] java.lang.ClassCastException: java.util.LinkedHashMap cannot be cast to java.lang.Long
    2011-09-24 22:58:25 [SEVERE] at com.iCo6.Constants$Nodes.getLong(
    2011-09-24 22:58:25 [SEVERE] at com.iCo6.iConomy$
    2011-09-24 22:58:25 [SEVERE] at
  19. Offline


    Sorry to bump, but any help is really welcome!
  20. Offline


    If i got u right u`ll have to Change the Default initial account holdings in the config to 0.
    As far as I know there is no way to give that default holding to a specific permissiongroup.
    BadDog likes this.
  21. Offline


    Any chance of a list of compatible permissions plugins?
    Using PermissionsBukkit and can't apply permissions to regular players.
  22. Offline


    Thats odd... It works like that with the old one, I havent changed anything. Im just using the old one for now. Seems to work with #1185. Not sure there is a reason to change till this gets figured out.
  23. Offline


    I'm totally having the same problem! Updated from Mc1.7.3 to 1.8. I copied the db files from 5.01 to 6.0.3 , left all the settings the same and it gives me the " No suitable driver found for jdbc:mysql:\\localhost:3306\iConomy " error! I can't create accounts manually either. I guess its just something that will have to be waited out???
  24. Offline


    @Nijikokun I get this error after updated from 5->6 for my new players.

    iConomy: Error issueing SQL query: java.sql.SQLException: Unknown column 'status' in 'field list' Query: INSERT INTO iConomy(username, balance, status) values (?, ?, ?) Parameters: [frostyhell, 250.0, 0]

    With 250 being the starting balance.
    Tendonsie likes this.
  25. Offline


    Thanks for your help maxp0wer789, I'll do that.
  26. Offline


    I got the same error.
  27. Offline


    Is this supported by PEX? (Permissionsex)?
  28. Offline


    How can i download an older version (iConomy 5) Of this?
  29. Offline


    it doens't work whit 1185
    i cant use /money
    and any time i recet the server, it rescet the money price
    can u fix it?
  30. Offline


    iConomy 6 has some huge database issues anyway. Crashed my Server yesterday.
    I think it's best to switch back to iconomy5 and wait til nijikokun did some bug fixing.

    But I'm pretty sure u can't use MySQL on a local mashine. (Please correct me if I'm wrong)
    should be something like:
    jdbc:mysql:\\(your MySQL-Server IP):3306\(your databasename)

    You can pm me with your config-file maybe I can figure out the problem.
  31. Offline


    This is because the MySQL table has not been updated to have a "status" column instead of a "hidden" column. The 5->6 upgrade does not seem to work properly. In fact, it seems to do nothing at all.

Share This Page