CraftBukkit for Minecraft 1.6.4 DEVELOPMENT build is now available!

Discussion in 'Bukkit News' started by EvilSeph, Sep 20, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit for Minecraft 1.6.4 DEVELOPMENT build is now available!

    As of this post, we've shifted development over to Minecraft 1.6.4 compatibility and now have development builds available. We strongly suggest that you only use this build if you would like to help us get a Beta build out sooner and are experienced with using unsupported development builds. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

    WARNING: Minecraft 1.6.4 is an update that requires clients to update before being able to connect.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine. Unless we specifically have to break plugins or the plugins you are using are employing inappropriate practises, most plugins should work without needing an update whenever we put out a new release.

    What is a Developer Build?
    A Developer build is provided AS IS and COMPLETELY UNSUPPORTED. You should only be running these builds if you are completely aware of how to properly make use of them. Support requests of ANY KIND will be removed without warning. If you have to ask where or how to get the development build, you should NOT be running it and posts of that nature will be deleted.

    Known Issues:
    • None
  2. That was fast.

    The Bukkit team give no ETAs, and with good reason.

    NB! Wikipedia is cited as a general overview of the topic of Hofstadter's Law, and is not to be used as a very reliable or detailed source.
    HarveyCrumpet likes this.
  3. well normally if ya release a version EJC, you list it so ya can post bugs. But apparently everyone is playing hush hush on this version There was no info at all on 1.46 offically from mojang till 2 days ago when they finally announced that the 1.46 was an official release..
  4. Offline


    Awesome can't wait for 1.7.
  5. Offline


    Excellent, keep up the great work guys.
  6. I know its weird to ask this, but 1.6.4 is a safe update? Cause I dont want those "xploit" s* happening again. I will do a test server with current plugins to see if it works (checking plugins) before updating my main server. Thanks for the fast update, Bukkit Team!
  7. Offline


    Good job! I'm crazy with excitement to get the Beta version of Bukkit!!!
  8. I think bukkit should worry about 1.7 more than 1.6.4. The server snapshots were released and I think they should start one those instead of 1.6.4. Just sayin.
  9. Offline


    For some reason, whenever I go to download it, it says "sorry, page not available" (I'm on Windows)
  10. CG_Sharktooth

    I believe there was some downtime yesterday, I think it is back now :)
  11. Offline


    Agreed. But then you'll get the people saying 'where is 1.6.4' As much as 1.7 is close and it's a much bigger update.. I'm sure they will work on it as soon as they can :)
  12. Offline


    Thanks! Keep it up!
    I hope it doesn't take long for a Beta and Recommended build to roll out, since there are not too many new features in 1.6.4
  13. Offline


    I am impressed that u had it up in time for the 1.6.4 update. Although I'm upset that 1.6.2's recommended build came out as soon as 1.6.4. I love y'all for updating it though. Keep up the work and please notify me when beta is out. EvilSeph
  14. Is something up with ? Looks like it's down in some way, I can't grab the dev build...
  15. 2+ Weeks since any changes to the code... what's going on did you guys give up or just not bothering releasing a beta or recommended this downtime is bothering me... are you just not bothering because you'd rather wait for 1.7? what happened to the nightly automatic builds did you guys stop that it seems that not one thing has been done since Sept 20th on this.
  16. Offline


    I'm amazed that noone noticed a spelling mistake:

    Or... is that a british way of spelling?

    Anyway, "practises" should be "practices"

  17. Offline

    TnT Retired Staff

    practises (open)


    practises 3rd person singular present of prac┬Ětice (Verb)

    1. Perform (an activity) or exercise (a skill) repeatedly or regularly in order to improve or maintain one's proficiency.
    2. Carry out or perform (a particular activity, method, or custom) habitually or regularly.

    Embarrassing indeed.
    drtshock likes this.
  18. I believe they're under a code freeze due to 1.7 being just around the corner. My guess was they needed to get something together to tide us over until 1.7 came out.

    This post is mostly a semi-educated guess and should not be used as a reliable source.
  19. Offline


    is there any way for a uneducated wanna-be programmer that doesn't hardly know anything about java to use the 1.6.4 development and report problems to other people who know how to program and fix the issues? I'd like to help with the developments but don't know any programming yet(i'm learning). In other words, I'd like to be a development tester/debugger/quality assurance tester... you get the picture...Is there anywhere to post issues, problems, or suggestions?
  20. Offline

    TnT Retired Staff

    This is incredibly off topic, but if you want to help out you can look at the leaky bug tracker and provide reproduction steps for problems reported, or reproduce problems and verify they can be reproduced on problems that have reproduction steps.
  21. TnT I think in this case, it isn't used as a verb though...
  22. I can not imagine how hard it will be to upgrade to 1.7 It adds almost 1000 new biomes. The team will have to update the world generation and world API and do their best to keep up with current plugin implementations. Prepare for half of the plugins breaking and a massive wait time. Hooray for Minecraft updates! :p
  23. That's why I'm hoping for a 1.6.4 Recommended build. There's one plugin I use that is broken with 1.6.4, and they're not going to update until Bukkit is more stable! If that plugin gets updated, I can just stick with 1.6.4 for a long time until the upcoming 1.7 mess is straightened out.
  24. Offline


    So, I've seen the warning suggesting that servers run on 1.6.4 and run around loading your chunks in order to "fix map bugs" before upgrading to 1.7. That suggests to me that I want to get on 1.6.4 sooner rather than later, to allow for my players to do their thing and load those chunks... however, I'm leery of upgrading to a DEV build, especially one that does map changes that might not be reversible (i.e. it might be bard to roll back to 1.6.2.)

    This whole thing sounds strange to me-- I can't imagine why 1.7 would break a 1.6.2 map but be OK with a 1.6.4 map. I would assume that whatever fixit code is in 1.6.4 could also be in 1.7.

    Does anybody have some solid information on where this is headed? Specifically, I am wondering:
    * Will there be a BETA or RECOMMENDED build of 1.6.4?
    * If I skip 1.6.4, am I at increased risk of map corruption?

    (And is there a better forum for this sort of thing?)
  25. Offline

    TnT Retired Staff

    1.6.4 introduced the concept of saving your structures (as in Nether Fortresses, not player made structures) to the map. This is for when 1.7 comes out, your map will know a Nether Fortress is where it looks to be in game, resulting in proper mob spawning. Without saving structures, your map may think a Nether Fortress is somewhere completely different. Your players will get very confused why they can no longer find Wither Skeletons or Blazes where they used to find them.

    We are working toward a RB for 1.6.4, but due to technical difficulties this has taken us longer than we wish. You will see the problems listed above if you do not update. I would recommend using the latest dev build at this time to make sure your structures can save properly. If you do not have those structures saved, you will have difficulties using old (pre-1.7) worlds come 1.7.
    cseraphi likes this.
  26. Offline


    Thanks for the recommendation, and I just updated my server to the dev build. Does a player need to re-explore all of the already generated chunks to "save" them?
  27. Offline

    TnT Retired Staff

  28. Offline


    Oh man. :eek:

    This would take significant time even if I set myself on creative mode and flew around. Any suggestions or possible workarounds?
  29. Offline


    Snag WorldEdit and use the compass to 'port around. Much faster than flying, especially if you go into the config file and bump up the max distance.
  30. Offline


    Just to clarify please; I have 12 worlds, including nether and end. So chunks I do not visit using 1.6.4, would be lost if I did not visit (explore) these chunks? If so, WOW, it just put a knot in my stomach. I have some large worlds....
  31. Offline

    TnT Retired Staff

    No, you will not lose your world. However, structures such as Witch Huts and Nether Fortresses would not be detectable by the server if you do not load those chunks in 1.6.4. This means your server would not know how to generate mobs specific to those structures (no more naturally occurring Wither Skeletons, or Witches).
Thread Status:
Not open for further replies.

Share This Page