Could not load "plugins/AdminShop"

Discussion in 'Plugin Development' started by Emphytos, Mar 18, 2012.

  1. Offline

    Emphytos

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Hi,

    I create the plugin AdminShop, players can sell their items with sign.

    On my local server I don't have any error, but on my debian server, I've this error:
    Code (Text):
    1.  
    2. [LIST=1]
    3. [*]17:11:09 [SEVERE] Could not load 'plugins/AdminShop.jar' in folder 'plugins'
    4. [*]org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: fr/emphytos/adminshop/AdminShop : Unsupported major.minor version 51.0
    5. [*]        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:150)
    6. [*]        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:287)
    7. [*]        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:211)
    8. [*]        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:207)
    9. [*]        at org.bukkit.craftbukkit.CraftServer.reload(CraftServer.java:537)
    10. [*]        at org.bukkit.Bukkit.reload(Bukkit.java:182)
    11. [*]        at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:22)
    12. [*]        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:166)
    13. [*]        at org.bukkit.craftbukkit.CraftServer.dispatchCommand(CraftServer.java:469)
    14. [*]        at org.bukkit.craftbukkit.CraftServer.dispatchServerCommand(CraftServer.java:465)
    15. [*]        at net.minecraft.server.MinecraftServer.b(MinecraftServer.java:599)
    16. [*]        at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:568)
    17. [*]        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:452)
    18. [*]        at net.minecraft.server.ThreadServerApplication.run(SourceFile:490)
    19. [*]Caused by: java.lang.UnsupportedClassVersionError: fr/emphytos/adminshop/AdminShop : Unsupported major.minor version 51.0
    20. [*]        at java.lang.ClassLoader.defineClass1(Native Method)
    21. [*]        at java.lang.ClassLoader.defineClass(ClassLoader.java:634)
    22. [*]        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    23. [*]        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
    24. [*]        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
    25. [*]        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
    26. [*]        at java.security.AccessController.doPrivileged(Native Method)
    27. [*]        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
    28. [*]        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:41)
    29. [*]        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:29)
    30. [*]        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
    31. [*]        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
    32. [*]        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:334)
    33. [*]        at java.lang.Class.forName0(Native Method)
    34. [*]        at java.lang.Class.forName(Class.java:264)
    35. [*]        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:139)
    36. [*]        ... 13 more
    37. [/LIST]
    38.  
    I really don't know why I've this error, my others plugins work !

    Thanks
     
  2. Offline

    dsmyth1915

    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    Your running the server in a Java 7 environment. Try running it in a JRE6
     
  3. Offline

    kumpelblase2

    My BukkitDev Profile
    My Plugins (2)
    dev.bukkit.org profile:
    CFUSERNAME
    My Plugins (CFCOUNT)
    Minecraft account:
    MCUSERNAME
    it's not because of the server, it's because he's using java 7 to build the plugin.
     

Share This Page