Can't enable PVP on my server

Discussion in 'Bukkit Help' started by Kittycatster, Jan 27, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    Kittycatster

    I am having a problem on my server that when you try to do PVP you get a message in white saying "PVP Dissabled Here". In my server properties file PVP is set to true and when I get rid of all the mods on my server PVP works just fine.

    Here are the mods I have on my server:
    WorldEdit
    Parallel_Worlds_Engine
    DisguiseCraft
    CoreProtect
    BeHerobrine
    CommandSign
    Multiverse-Core
    The_Hidden
    LogBlock
    ConsoleSay
    MobArena
    WorldGuard
    warptastic
    Essentials
    EssentialsXMPP
    EssentialsProtect
    EssentialsChat
    EssentialsAntiBuild

    Permissions:
    groups:
    default:
    default: true
    permissions:
    - modifyworld.*
    - worldedit.reload
    - worldedit.selection
    - worlds.creative.worldedit.region
    - multiverse.portal.access.*
    - warptastic.warp
    - bukkit.command.help
    - essentials.fly
    - essentials.protect.pvp
    - essentials.signs.use.*
    - Telepay.tpa
    - Telepay.tpahere
    - Telepay.spawn
    - Telepay.home
    - Telepay.sethome
    - Telepay.back
    - warptastic.list
    - worldguard.region.wand
    - worldguard.region.define
    - worldguard.region.claim
    - worldguard.region.select.own.*
    - worldguard.region.select.member.*
    - worldguard.region.info.own
    - worldguard.region.addmember.own.*
    - worldguard.region.removemember.own.*
    - worldguard.region.list.own
    - worldguard.region.flag.regions.own.*
    - worldguard.region.flag.regions.*
    - worldguard.region.flag.flags.*
    - worldguard.region.setpriority.own.*
    - worldguard.region.setparent.own.*
    - worldguard.region.teleport.*
    - worldguard.region.remove.own.*
    - worldedit.region.set
    - worldedit.region.replace
    - worldedit.clipboard.copy
    - worldedit.clipboard.cut
    - worldedit.clipboard.paste
    - worldedit.generation.cylinder
    - worldedit.generation.pyramid
    - worldedit.history.redo
    - worldedit.history.undo
    - worldedit.region.move
    - worldedit.wand
    - worldedit.selection.pos
    - worldedit.selection.hpos
    - worldedit.wand.toggle
    - worldedit.selection.expand
    - worldedit.navigation.jumpto.tool
    - worldedit.navigation.thru.tool
    - essentials.vanish.pvp
    - essentials.home.bed
    - essentials.god.pvp
    - essentials.msg
    - essentials.tpdeny
    - essentials.afk
    - essentials.tpaccept
    - essentials.tpahere
    - essentials.nick
    - essentials.protect.pvp
    - permissions.build
    - Modifyworld
    - modifyworld.*
    - permissions.destroy
    - Permissions.Build.*
    - Permissions.build
    - Permissions.Modifyworld.*
    - Permissions.Modifyworld

    Server Properties File:
    #Minecraft server properties
    #Mon Jan 28 16:32:59 EST 2013
    generator-settings=
    allow-nether=true
    level-name=world
    enable-query=true
    allow-flight=false
    server-port=25565
    query.port=25565
    level-type=DEFAULT
    enable-rcon=false
    level-seed=
    server-ip=
    max-build-height=256
    spawn-npcs=true
    white-list=false
    debug=false
    spawn-animals=true
    texture-pack=
    hardcore=false
    snooper-enabled=true
    online-mode=true
    pvp=true
    difficulty=3
    server-name=Unknown Server
    gamemode=0
    max-players=50
    spawn-monsters=true
    generate-structures=true
    view-distance=10
    spawn-protection=16
    motd=Come to our server and join the fun.

    More information:
    The server is a bukkit server and it is on 1.4.7
    Server ip: dreampark.no-ip.org

    Video of problem:
     
  2. Offline

    MayoDwarf

    Has nothing to do with permissions! Go to server.properties file located in server folder and look for pvp= and put this:
    pvp=true

    Welcome
    - Jared
     
  3. Offline

    Kittycatster

    Thanks for trying to help but PVP was already on true in my server.properties file and PVP only works with that option when I get rid of all my mods.
     
  4. Offline

    MayoDwarf

    Get rid of essentialsprotect and essentialsantibuild and the problem should be fixed. - Jared
     
  5. Did you do what I told you on your server? Beacuse if you did I will come on now and fix it
     
  6. Offline

    MayoDwarf

    Kittycatster The problem is Parallel_Worlds_Engine. I already fixed this for another server. Remove that plugin and PVP will work again! - Jared
     
  7. Offline

    Necrodoom

    no.
    stop suggesting deleting unrelated jars as a solution to all problems. please read what they do.
     
  8. Offline

    MayoDwarf

    I already fixed the problem on another server... Now do not talk if you do not know what you are talking about. This is the solution to the problem.
     
  9. Offline

    Necrodoom

    essentialsantibuild does absolutely nothing with PVP.
    essentialsprotect has PVP protection disabled by default.
    i think that means you shouldnt talk?
     
    bennie3211 likes this.
  10. Offline

    MayoDwarf

    I never said that... I said that parallel_world causes the problem and it does. And also how rude can you be...
     
  11. Offline

    Kittycatster

    Well getting rid of the jars or parallel_world_engine didn't work
     
  12. Offline

    Kittycatster

    WorldEdit now works
     
  13. ip?
     
  14. Offline

    Kittycatster

    dreampark.no-ip.org
     
Thread Status:
Not open for further replies.

Share This Page